Server Requirements for Expert Script

ExpertScript Server Requirements

Just To run our Answer Script, servers are required to have the following setup:

  • Apache web server with mod_rewrite enabled.
  • GD Library 2+ with freetype support.
  • PHP 5.2+ with the following configuration
    1. safe_mode = off
    2. open_basedir = (no value)
    3. output_buffering = on
    4. register_argc_argv = On
    5. max_execution_time = 300 (Recommended or higher)
    6. session.gc_maxlifetime = 15000 (Recommended or higher)
    7. upload_max_filesize = 5M (Recommended or higher)
    8. post_max_size = 5M (Recommended or higher)
    9. register_globals = off
    10. magic_quotes_gpc = on
    11. short_open_tag = on
    12. allow_url_fopen = on
    13. strict standards off (~E_STRICT)
  • MySQL version 4.0+
  • MySQL "SQL_MODE" setting NOT set to STRICT_TRANS_TABLES
  • Apache MultiViews disabled
  • Ability to run a cron job once per hour
  • Ability to run PHP from the command line (CLI) with exec()
  • Ability to execute background processes with exec("binary > /dev/null &")


Need Hosting For Expert Script?

View ExpertScript Recommended Web Hosts


Already have hosting and just need a Server Setup?

Let us setup your server for you, Click here to order a server setup service.